RIP, EIGRP, OSPF, IS-IS, BGP, MPLS, VTP, STP.
User avatar
dieselboy
Post Whore
Posts:
2747
Joined:
Tue Aug 05, 2008 6:36 am
Certs:
CCNP, CCNA Voice, SMB Select, Linux+

Input errors on Multilink but not physical Serial's

Tue Aug 10, 2010 11:55 am

Just recently began seeing incrementing errors on a multilink logical interface on some kit connecting to E1 Circuits.
The router has been in for 36 weeks and only the passed couple weeks started seeing incrementing errors on the Mu1 interface. There was a service policy applied to the Mu1 which I have since removed and am now seeing output drops also, although the bandwidth never reaches above 2mbit/s and the general usage is <0.5mbit/s.
I looked into this because of a bandwidth / packet loss type issue being seen with the two bundled circuits.
I've contacted the ISP which are USA based to check our configs and they state everything looks good there. They have involved their UK last leg supplier who also state no issues with the E1s.

Since the providers cannot see any reasons for this and our configs are supposed to be good, but the errors are incrementing, can anyone thing of a reason(s) for this?
Granted the number of errors are low compared to packets, this wasn't happening at all before and now it is increasing more.

Below are the config and show interface for reference.

Code: Select all
[b]show run[/b]
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname xxx-2811-1
!
boot-start-marker
boot-end-marker
!
card type e1 0 2
card type e1 0 3
security authentication failure rate 3 log
logging message-counter syslog
logging buffered 40960
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
aaa session-id common
clock timezone GMT 0
clock summer-time GMT recurring last Sun Mar 1:00 last Sun Oct 1:00
no network-clock-participate wic 2
no network-clock-participate wic 3
!
dot11 syslog
no ip source-route
!
!
ip cef
!
!
no ip bootp server
no ip domain lookup
ip vrf DIA
 description WWW Internet VRF
 rd x.x.x.x:1
!
ip vrf MPLS
 description MPLS VRF
 rd x.x.x.x:2
!
multilink bundle-name authenticated
!
!
!
!
!
archive
 log config
  hidekeys
!
!
controller E1 0/2/0
 channel-group 0 timeslots 1-31
!
controller E1 0/3/0
 channel-group 0 timeslots 1-31
!
controller E1 0/3/1
 channel-group 0 timeslots 1-31
!
ip tcp synwait-time 10
ip telnet source-interface FastEthernet0/1
ip tftp source-interface FastEthernet0/1.70
!
!
!
!
!
interface Loopback0
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
!
interface Null0
 no ip unreachables
!
interface Multilink1
 description Bundled MPLS Circuits
 ip vrf forwarding MPLS
 ip address x,x,x,x 255.255.255.252
 ip access-group MPLS-to-2800 in
 ip access-group deny-out-to-mpls out
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 ppp multilink
 ppp multilink group 1
!
interface FastEthernet0/0
 description 100M FD interface to ASA5510 E0/0
 ip vrf forwarding IA
 ip address x.x.x,x 255.255.255.240
 ip access-group inside-to-2800 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 duplex full
 speed 100
 no mop enabled
!
interface FastEthernet0/1
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 duplex full
 speed 100
 no mop enabled
!
interface FastEthernet0/1.70
 description LAN facing interface
 encapsulation dot1Q 70
 ip vrf forwarding MPLS
 ip address 192.168.205.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
!
interface Serial0/2/0:0
 description WWW Internet facing - Circuit ID xxx
 ip vrf forwarding DIA
 ip address 63.229.104.146 255.255.255.252
 ip access-group wan-to-2800 in
 ip verify unicast reverse-path
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
!
interface Serial0/3/0:0
 description MPLS link 1  - Circuit ID xxxx
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
interface Serial0/3/1:0
 description MPLS link 2 - Circuit ID xxxx
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip flow ingress
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
!
ip forward-protocol nd
ip route vrf  DIA 0.0.0.0 0.0.0.0 xxxx
ip route vrf  MPLS 0.0.0.0 0.0.0.0 xxxx
ip route vrf  MPLS x 255.255.248.0 xxxx
ip route vrf  MPLS x 255.255.255.0 xxxx
ip route vrf  MPLS x 255.255.255.0 xxxx
ip route vrf  MPLS x 255.255.255.0 xxxx
ip route vrf  MPLS x 255.255.255.0 xxxx
ip route vrf  MPLS x 255.255.255.0 xxxxx
!
ip http server
ip http access-class 80
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip access-list standard Vty-Access
 permit x
!
ip access-list extended MPLS-to-2800
 permit ip x
 deny   ip any any log
ip access-list extended deny-out-to-mpls
 deny   icmp x 0.0.0.255 any unreachable log
 permit ip any any
ip access-list extended inside-to-2800
 deny   ip 192.168.0.0 0.0.255.255 any
 deny   ip 10.0.0.0 0.255.255.255 any
 deny   ip 172.0.0.0 0.31.255.255 any
 permit ip x 0.0.0.15 any
 permit ip host x any
 permit ip x 0.0.0.127 any
 deny   ip any host x
 permit ip any any

ip access-list extended wan-to-2800
 permit ip x 0.0.0.7 any
 permit ip host x any
 permit ip host x any
 permit ip host x any
 permit icmp host x any
 permit icmp host x any
 permit tcp host x eq 123 host x
 permit tcp host xeq 123 host x
 deny   ip any host x
 deny   ip any host x
 permit ip any any
!
access-list 80 permit x
no cdp run

!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
scheduler allocate 20000 1000
end



Code: Select all
[b]Show interface's[/b]
Serial0/3/0:0 is up, line protocol is up
  Hardware is GT96K Serial
  Description: MPLS link 1  - Circuit ID
  MTU 1500 bytes, BW 1984 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open, multilink Open
  Link is a member of Multilink bundle Multilink1, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:05, output hang never
  Last clearing of "show interface" counters 4d03h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair  [suspended, using FIFO]
  FIFO output queue 0/40, 0 drops
  5 minute input rate 10000 bits/sec, 5 packets/sec
  5 minute output rate 11000 bits/sec, 20 packets/sec
     1001596 packets input, 251095741 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1503049 packets output, 195765219 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
  Timeslot(s) Used:1-31, SCC: 0, Transmitter delay is 0 flags
 

Serial0/3/1:0 is up, line protocol is up
  Hardware is GT96K Serial
  Description: MPLS link 2 - Circuit ID x
  MTU 1500 bytes, BW 1984 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 2/255
  Encapsulation PPP, LCP Open, multilink Open
  Link is a member of Multilink bundle Multilink1, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:06, output hang never
  Last clearing of "show interface" counters 4d03h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair  [suspended, using FIFO]
  FIFO output queue 0/40, 0 drops
  5 minute input rate 23000 bits/sec, 34 packets/sec
  5 minute output rate 12000 bits/sec, 21 packets/sec
     1506855 packets input, 286483710 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     1503191 packets output, 195762406 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
  Timeslot(s) Used:1-31, SCC: 1, Transmitter delay is 0 flags
 

Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Description: Bundled MPLS Circuits
  Internet address is x/30
  MTU 1500 bytes, BW 3968 Kbit/sec, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 3/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: IPCP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  Last input 00:02:52, output never, output hang never
  Last clearing of "show interface" counters 4d03h
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 45
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 57000 bits/sec, 39 packets/sec
  5 minute output rate 25000 bits/sec, 40 packets/sec
     2366597 packets input, 526739045 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     423 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     2347607 packets output, 389548575 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
   
   
Meanwhile, back in the city...

javentre
Post Whore
Posts:
1971
Joined:
Fri Jul 09, 2010 7:38 pm

Re: Input errors on Multilink but not physical Serial's

Tue Aug 10, 2010 12:22 pm

Please post:

sh ver | inc IO
show service-module for each of the T1s.
http://networking.ventrefamily.com

User avatar
dieselboy
Post Whore
Posts:
2747
Joined:
Tue Aug 05, 2008 6:36 am
Certs:
CCNP, CCNA Voice, SMB Select, Linux+

Re: Input errors on Multilink but not physical Serial's

Tue Aug 10, 2010 1:37 pm

javentre wrote:Please post:

sh ver | inc IO
show service-module for each of the T1s.


Code: Select all
2811-1#sh ver | inc IO
Cisco IOS Software, 2800 Software (C2800NM-IPBASEK9-M), Version 12.4(24)T1, RELEASE SOFTWARE (fc3)


The show service-module command is not recognised but here is a show controllers for the e1's

Code: Select all
E1 0/3/0 is up.
  Applique type is Channelized E1 - balanced
  Cablelength is Unknown
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20090408, FPGA: 13, spm_count = 0
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (428 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
E1 0/3/1 is up.
  Applique type is Channelized E1 - balanced
  Cablelength is Unknown
  No alarms detected.
  alarm-trigger is not set
  Version info Firmware: 20090408, FPGA: 13, spm_count = 0
  Framing is CRC4, Line Code is HDB3, Clock Source is Line.
  Data in current interval (430 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
  Total Data (last 24 hours)
     0 Line Code Violations, 0 Path Code Violations,
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs


Cheers
Meanwhile, back in the city...

User avatar
dieselboy
Post Whore
Posts:
2747
Joined:
Tue Aug 05, 2008 6:36 am
Certs:
CCNP, CCNA Voice, SMB Select, Linux+

Re: Input errors on Multilink but not physical Serial's

Tue Aug 10, 2010 1:40 pm

Here is the show controllers for the serial's
Code: Select all
Interface Serial0/3/0:0
Hardware is GT96Kidb at 0x455ABC14, driver data structure at 0x455AD38C
wic_info 0x0
Physical Port 6, SCC Num 6
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000100
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x00000648, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080
CRDP=0x0F9EDDF0, CTDP=0x0F9EE610, FTDB=0x0F9EE610
Main Routing Register=0xBB797777 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x00000000 Tx Clk Routing Register=0x00000000
GPP Registers:
Conf=0x55115511, Io=0x55115511, Data=0xFFCEFFCE, Level=0x00000000
FTDM Registers:
&TCR=0xB400C308, TCR=0x80802500
&tdpram[0]=0xB400B000, tdpram[0]=0xC06FF
&tdpram[1]=0xB400B004, tdpram[1]=0xC06FF
&tdpram[2]=0xB400B008, tdpram[2]=0xC06FF
&tdpram[3]=0xB400B00C, tdpram[3]=0xC06FF
&tdpram[4]=0xB400B010, tdpram[4]=0xC06FF
&rdpram[0]=0xB400B400, rdpram[0]=0x20C07FF
&rdpram[1]=0xB400B404, rdpram[1]=0xC06FF
&rdpram[2]=0xB400B408, rdpram[2]=0xC06FF
&rdpram[3]=0xB400B40C, rdpram[3]=0x20C07FF
&rdpram[4]=0xB400B410, rdpram[4]=0xC07FF
TDM FPGA Registers:
vmcr[0] = 0x00000000, vmcr[1] = 0x00000000,
vmcr[2] = 0x00000003, vmcr[3] = 0x00000003
ntrcr0 = 0x00000000, ntrcr1 = 0x00000000
tdmcr = 0x0000006A, labcr = 0x00000000, tpllr_cr = 0x00000000
nhr = 0x26266666, isr = 0x0000FFFF, imr = 0x00000000
44 input aborts on receiving flag sequence
0 throttles, 0 enables
3 overruns
0 transmitter underruns
0 transmitter CTS losts
129497839 rxintr, 155014219 txintr, 0 rxerr, 0 txerr
230311190 mpsc_rx, 0 mpsc_rxerr, 22 mpsc_rlsc, 8201 mpsc_rhnt, 230303056 mpsc_rfsc
8173 mpsc_rcsc, 0 mpsc_rovr, 0 mpsc_rcdl, 0 mpsc_rckg, 0 mpsc_bper
2 mpsc_txerr, 148227108 mpsc_teidl, 2 mpsc_tudr, 0 mpsc_tctsl, 0 mpsc_tckg
0 sdma_rx_sf, 0 sdma_rx_mfl, 3 sdma_rx_or, 44 sdma_rx_abr, 40 sdma_rx_no
0 sdma_rx_de, 0 sdma_rx_cdl, 209 sdma_rx_ce, 0 sdma_tx_rl, 0 sdma_tx_ur, 0 sdma_tx_ctsl
0 sdma_rx_reserr, 0 sdma_tx_reserr
0 rx_bogus_pkts, rx_bogus_flag FALSE
0 sdma_tx_ur_processed
fport 6, 0 ftdm_rint, 0 ftdm_rsl, 0 ftdm_tint, 0 ftdm_tsl
~~~
Interface Serial0/3/1:0
Hardware is GT96Kidb at 0x455B0588, driver data structure at 0x455B1D00
wic_info 0x0
Physical Port 6, SCC Num 7
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000100
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x00000648, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080
CRDP=0x0FA07FE0, CTDP=0x0FA08710, FTDB=0x0FA08710
Main Routing Register=0xBB797777 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x00000000 Tx Clk Routing Register=0x00000000
GPP Registers:
Conf=0x55115511, Io=0x55115511, Data=0xFFCEFFCE, Level=0x00000000
FTDM Registers:
&TCR=0xB400C308, TCR=0x80802500
&tdpram[0]=0xB400B000, tdpram[0]=0xC06FF
&tdpram[1]=0xB400B004, tdpram[1]=0xC06FF
&tdpram[2]=0xB400B008, tdpram[2]=0xC06FF
&tdpram[3]=0xB400B00C, tdpram[3]=0xC06FF
&tdpram[4]=0xB400B010, tdpram[4]=0xC07FF
&rdpram[0]=0xB400B400, rdpram[0]=0xC07FF
&rdpram[1]=0xB400B404, rdpram[1]=0xC06FF
&rdpram[2]=0xB400B408, rdpram[2]=0xC07FF
&rdpram[3]=0xB400B40C, rdpram[3]=0xC07FF
&rdpram[4]=0xB400B410, rdpram[4]=0xC07FF
TDM FPGA Registers:
vmcr[0] = 0x00000000, vmcr[1] = 0x00000000,
vmcr[2] = 0x00000003, vmcr[3] = 0x00000003
ntrcr0 = 0x00000000, ntrcr1 = 0x00000000
tdmcr = 0x0000006A, labcr = 0x00000000, tpllr_cr = 0x00000000
nhr = 0x26266666, isr = 0x0000FFFF, imr = 0x00000000
26 input aborts on receiving flag sequence
0 throttles, 0 enables
8 overruns
0 transmitter underruns
0 transmitter CTS losts
180636404 rxintr, 155021227 txintr, 0 rxerr, 0 txerr
331269490 mpsc_rx, 0 mpsc_rxerr, 26 mpsc_rlsc, 183 mpsc_rhnt, 331269341 mpsc_rfsc
158 mpsc_rcsc, 0 mpsc_rovr, 0 mpsc_rcdl, 0 mpsc_rckg, 0 mpsc_bper
1 mpsc_txerr, 148227347 mpsc_teidl, 1 mpsc_tudr, 0 mpsc_tctsl, 0 mpsc_tckg
0 sdma_rx_sf, 0 sdma_rx_mfl, 8 sdma_rx_or, 26 sdma_rx_abr, 28 sdma_rx_no
0 sdma_rx_de, 0 sdma_rx_cdl, 265 sdma_rx_ce, 0 sdma_tx_rl, 0 sdma_tx_ur, 0 sdma_tx_ctsl
0 sdma_rx_reserr, 0 sdma_tx_reserr
0 rx_bogus_pkts, rx_bogus_flag FALSE
0 sdma_tx_ur_processed
fport 6, 0 ftdm_rint, 0 ftdm_rsl, 0 ftdm_tint, 0 ftdm_tsl
Meanwhile, back in the city...

javentre
Post Whore
Posts:
1971
Joined:
Fri Jul 09, 2010 7:38 pm

Re: Input errors on Multilink but not physical Serial's

Tue Aug 10, 2010 3:31 pm

Time for a TAC Case.

Asking around, I've heard of other folks having that issue fixed by a code upgrade, but no one can point to a BugID to prove it was fixed by code and not just a reboot.
http://networking.ventrefamily.com

User avatar
dieselboy
Post Whore
Posts:
2747
Joined:
Tue Aug 05, 2008 6:36 am
Certs:
CCNP, CCNA Voice, SMB Select, Linux+

Re: Input errors on Multilink but not physical Serial's

Tue Aug 10, 2010 4:02 pm

Thanks for the info!!
I'll request a reload and see if it still increments. If it does then next step will be a image change. It's out of TAC though.
If it resolves I'll post back either way!

Thanks again.
Meanwhile, back in the city...

javentre
Post Whore
Posts:
1971
Joined:
Fri Jul 09, 2010 7:38 pm

Re: Input errors on Multilink but not physical Serial's

Tue Aug 10, 2010 4:27 pm

dieselboy wrote:44 input aborts on receiving flag sequence
26 input aborts on receiving flag sequence


This smells like a framing issue, but that's not a lot of errors considering the total number of processed packets on those interfaces. You've got 2.3M packets on input, and we're concerned with 70.

Thanks to a smart co-worker of mine:
http://tools.ietf.org/html/rfc2175
Flag Sequence

Flag sequence is used for frame synchronization. Each frame begins
and ends with a flag sequence 01111110 (0x7E). If a frame
immediately follows another, one flag sequence may be treated as
the end of the preceding frame and the beginning of the immediately
following frame. When the line is idle, the flag sequence is to be
transmitted continuously on the line.
http://networking.ventrefamily.com

User avatar
dieselboy
Post Whore
Posts:
2747
Joined:
Tue Aug 05, 2008 6:36 am
Certs:
CCNP, CCNA Voice, SMB Select, Linux+

Re: Input errors on Multilink but not physical Serial's

Wed Aug 11, 2010 3:06 am

Thank you, very helpful!
I did the reboot last night and just no when I have checked the interface there are 341 input errors out of 959109 packets. However now when I check the controllers for the serials there are Zero aborts on flag sequence :/

Code: Select all
Multilink1 is up, line protocol is up
  Hardware is multilink group interface
  Description: Bundled MPLS Circuits
  Internet address is x/30
  MTU 1500 bytes, BW 3968 Kbit/sec, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 23/255
  Encapsulation PPP, LCP Open, multilink Open
  Open: IPCP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 2 seconds on reset
  Last input 00:02:28, output never, output hang never
  Last clearing of "show interface" counters 10:51:25
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 368000 bits/sec, 44 packets/sec
  5 minute output rate 22000 bits/sec, 30 packets/sec
     959109 packets input, 976163067 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     341 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     600832 packets output, 44388987 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

Code: Select all
Interface Serial0/3/0:0
Hardware is GT96Kidb at 0x45464514, driver data structure at 0x45465484
wic_info 0x0
Physical Port 6, SCC Num 6
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000100
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x00000648, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00001008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080
CRDP=0x0F9F17D0, CTDP=0x0F9F19E0, FTDB=0x0F9F19E0
Main Routing Register=0xBB797777 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x00000000 Tx Clk Routing Register=0x00000000
GPP Registers:
Conf=0x55115511, Io=0x55115511, Data=0xFFCFFFCF, Level=0x00000000
FTDM Registers:
&TCR=0xB400C308, TCR=0x80802500
&tdpram[0]=0xB400B000, tdpram[0]=0xC07FF
&tdpram[1]=0xB400B004, tdpram[1]=0xC07FF
&tdpram[2]=0xB400B008, tdpram[2]=0xC07FF
&tdpram[3]=0xB400B00C, tdpram[3]=0xC07FF
&tdpram[4]=0xB400B010, tdpram[4]=0xC06FF
&rdpram[0]=0xB400B400, rdpram[0]=0xC06FF
&rdpram[1]=0xB400B404, rdpram[1]=0xC07FF
&rdpram[2]=0xB400B408, rdpram[2]=0xC06FF
&rdpram[3]=0xB400B40C, rdpram[3]=0xC06FF
&rdpram[4]=0xB400B410, rdpram[4]=0xC06FF
TDM FPGA Registers:
vmcr[0] = 0x00000000, vmcr[1] = 0x00000000,
vmcr[2] = 0x00000003, vmcr[3] = 0x00000003
ntrcr0 = 0x00000000, ntrcr1 = 0x00000000
tdmcr = 0x0000006A, labcr = 0x00000000, tpllr_cr = 0x00000000
nhr = 0x26266666, isr = 0x0000FFFF, imr = 0x00000000
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns
0 transmitter CTS losts
493186 rxintr, 329661 txintr, 0 rxerr, 0 txerr
762375 mpsc_rx, 0 mpsc_rxerr, 0 mpsc_rlsc, 4 mpsc_rhnt, 762372 mpsc_rfsc
4 mpsc_rcsc, 0 mpsc_rovr, 0 mpsc_rcdl, 0 mpsc_rckg, 0 mpsc_bper
0 mpsc_txerr, 328643 mpsc_teidl, 0 mpsc_tudr, 0 mpsc_tctsl, 0 mpsc_tckg
0 sdma_rx_sf, 0 sdma_rx_mfl, 0 sdma_rx_or, 0 sdma_rx_abr, 0 sdma_rx_no
0 sdma_rx_de, 0 sdma_rx_cdl, 0 sdma_rx_ce, 0 sdma_tx_rl, 0 sdma_tx_ur, 0 sdma_tx_ctsl
0 sdma_rx_reserr, 0 sdma_tx_reserr
0 rx_bogus_pkts, rx_bogus_flag FALSE
0 sdma_tx_ur_processed
fport 6, 0 ftdm_rint, 0 ftdm_rsl, 0 ftdm_tint, 0 ftdm_tsl


Code: Select all
Interface Serial0/3/1:0
Hardware is GT96Kidb at 0x44BF8928, driver data structure at 0x45466D4C
wic_info 0x0
Physical Port 6, SCC Num 7
MPSC Registers:
MMCR_L=0x000304C0, MMCR_H=0x00000000, MPCR=0x00000100
CHR1=0x00FE007E, CHR2=0x00000000, CHR3=0x00000648, CHR4=0x00000000
CHR5=0x00000000, CHR6=0x00000000, CHR7=0x00000000, CHR8=0x00000000
CHR9=0x00000000, CHR10=0x00003008
SDMA Registers:
SDC=0x00002201, SDCM=0x00000080
CRDP=0x0FA0BAE0, CTDP=0x0FA0C030, FTDB=0x0FA0C030
Main Routing Register=0xBB797777 BRG Conf Register=0x00480000
Rx Clk Routing Register=0x00000000 Tx Clk Routing Register=0x00000000
GPP Registers:
Conf=0x55115511, Io=0x55115511, Data=0xFFCFFFCF, Level=0x00000000
FTDM Registers:
&TCR=0xB400C308, TCR=0x80802500
&tdpram[0]=0xB400B000, tdpram[0]=0xC06FF
&tdpram[1]=0xB400B004, tdpram[1]=0xC06FF
&tdpram[2]=0xB400B008, tdpram[2]=0xC06FF
&tdpram[3]=0xB400B00C, tdpram[3]=0xC07FF
&tdpram[4]=0xB400B010, tdpram[4]=0xC07FF
&rdpram[0]=0xB400B400, rdpram[0]=0xC07FF
&rdpram[1]=0xB400B404, rdpram[1]=0xC06FF
&rdpram[2]=0xB400B408, rdpram[2]=0xC07FF
&rdpram[3]=0xB400B40C, rdpram[3]=0xC07FF
&rdpram[4]=0xB400B410, rdpram[4]=0xC06FF
TDM FPGA Registers:
vmcr[0] = 0x00000000, vmcr[1] = 0x00000000,
vmcr[2] = 0x00000003, vmcr[3] = 0x00000003
ntrcr0 = 0x00000000, ntrcr1 = 0x00000000
tdmcr = 0x0000006A, labcr = 0x00000000, tpllr_cr = 0x00000000
nhr = 0x26266666, isr = 0x0000FFFF, imr = 0x00000000
0 input aborts on receiving flag sequence
0 throttles, 0 enables
0 overruns
0 transmitter underruns
0 transmitter CTS losts
492745 rxintr, 330578 txintr, 0 rxerr, 0 txerr
760287 mpsc_rx, 0 mpsc_rxerr, 0 mpsc_rlsc, 4 mpsc_rhnt, 760284 mpsc_rfsc
4 mpsc_rcsc, 0 mpsc_rovr, 0 mpsc_rcdl, 0 mpsc_rckg, 0 mpsc_bper
0 mpsc_txerr, 329523 mpsc_teidl, 0 mpsc_tudr, 0 mpsc_tctsl, 0 mpsc_tckg
0 sdma_rx_sf, 0 sdma_rx_mfl, 0 sdma_rx_or, 0 sdma_rx_abr, 0 sdma_rx_no
0 sdma_rx_de, 0 sdma_rx_cdl, 0 sdma_rx_ce, 0 sdma_tx_rl, 0 sdma_tx_ur, 0 sdma_tx_ctsl
0 sdma_rx_reserr, 0 sdma_tx_reserr
0 rx_bogus_pkts, rx_bogus_flag FALSE
0 sdma_tx_ur_processed
fport 6, 0 ftdm_rint, 0 ftdm_rsl, 0 ftdm_tint, 0 ftdm_tsl
Meanwhile, back in the city...

Fred
Post Whore
Posts:
2617
Joined:
Sat Jun 07, 2008 11:06 am
Certs:
CCNP, CCDP

Re: Input errors on Multilink but not physical Serial's

Sat Aug 14, 2010 10:42 pm

If you haven't yet, you should take the output of 'show tech-support' and paste it into the Cisco Output interpreter. It will analyze these show commands and could give you insight into problems.

'

Return to Cisco Routing and Switching

Who is online

Users browsing this forum: No registered users and 122 guests