IPv6 design, deployment, standards, and best practices.
quatreduros
Junior Member
Posts:
77
Joined:
Wed Mar 07, 2012 5:27 pm
Certs:
CCNA, CCNP

Configuration RIPng

Thu May 03, 2012 3:16 pm

Hi,

I have configurated RIPng in Packet Tracer beacuse is compatible. The wrong is that not converge the routers. The routers not send the RIP routes to the adjacents routers.

Code: Select all
BARCELONA#sh ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
R   2001:1111:2222:2::/64 [120/1]
     via FE80::201:96FF:FE83:23DE, Serial0/0/0
     via FE80::2E0:A3FF:FE87:A29C, Serial0/2/0
C   2001:1111:2222:3::/64 [0/0]
     via ::, Serial0/0/0
L   2001:1111:2222:3::AC10:D606/128 [0/0]
     via ::, Serial0/0/0
C   2001:1111:2222:4::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:1111:2222:4::C0A8:101/128 [0/0]
     via ::, FastEthernet0/0
C   2001:1111:2222:5::/64 [0/0]
     via ::, Serial0/2/0
L   2001:1111:2222:5::AC10:D609/128 [0/0]
     via ::, Serial0/2/0
L   FF00::/8 [0/0]
     via ::, Null0


IBERCOM#sh ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   2001:1111:2222:2::/64 [0/0]
     via ::, Serial0/2/0
L   2001:1111:2222:2::AC10:D602/128 [0/0]
     via ::, Serial0/2/0
R   2001:1111:2222:3::/64 [120/1]
     via FE80::20C:85FF:FE18:B04D, Serial0/2/0
     via FE80::250:FFF:FE33:3516, Serial0/0/0
C   2001:1111:2222:5::/64 [0/0]
     via ::, Serial0/0/0
L   2001:1111:2222:5::AC10:D60A/128 [0/0]
     via ::, Serial0/0/0
C   2001:1111:2222:6::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:1111:2222:6::C0A8:201/128 [0/0]
     via ::, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0


VALENCIA#sh ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   2001:1111:2222:1::/64 [0/0]
     via ::, FastEthernet0/0
L   2001:1111:2222:1::C0A8:1/128 [0/0]
     via ::, FastEthernet0/0
C   2001:1111:2222:2::/64 [0/0]
     via ::, Serial0/2/0
L   2001:1111:2222:2::AC10:D601/128 [0/0]
     via ::, Serial0/2/0
C   2001:1111:2222:3::/64 [0/0]
     via ::, Serial0/0/0
L   2001:1111:2222:3::AC10:D605/128 [0/0]
     via ::, Serial0/0/0
R   2001:1111:2222:5::/64 [120/1]
     via FE80::290:21FF:FE29:2B1D, Serial0/0/0
     via FE80::2D0:BCFF:FE6B:7C33, Serial0/2/0
L   FF00::/8 [0/0]
     via ::, Null0


The configuration RIPng is OK

Code: Select all
BARCELONA#sh run
Building configuration...

Current configuration : 781 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname BARCELONA
!
!
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1111:2222:4::C0A8:101/64
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 ipv6 address 2001:1111:2222:3::AC10:D606/64
 ipv6 rip cisco enable
 clock rate 64000
!
interface Serial0/2/0
 no ip address
 ipv6 address 2001:1111:2222:5::AC10:D609/64
 ipv6 rip cisco enable
!
interface Vlan1
 no ip address
 shutdown
!
ipv6 router rip cisco
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!

IBERCOM#sh run
Building configuration...

Current configuration : 779 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname IBERCOM
!
!
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1111:2222:6::C0A8:201/64
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 ipv6 address 2001:1111:2222:5::AC10:D60A/64
 ipv6 rip cisco enable
 clock rate 64000
!
interface Serial0/2/0
 no ip address
 ipv6 address 2001:1111:2222:2::AC10:D602/64
 ipv6 rip cisco enable
!
interface Vlan1
 no ip address
 shutdown
!
ipv6 router rip cisco
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end


VALENCIA#sh run
Building configuration...

Current configuration : 778 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname VALENCIA
!
!
!
!
!
ipv6 unicast-routing
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:1111:2222:1::C0A8:1/64
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 no ip address
 ipv6 address 2001:1111:2222:3::AC10:D605/64
 ipv6 rip cisco enable
!
interface Serial0/2/0
 no ip address
 ipv6 address 2001:1111:2222:2::AC10:D601/64
 ipv6 rip cisco enable
 clock rate 64000
!
interface Vlan1
 no ip address
 shutdown
!
ipv6 router rip cisco
!
ip classless
!
!
!
no cdp run
!
!
!
!
!
line con 0
line vty 0 4
 login
!
!
!
end




Thanks,
Attachments
topology.jpg
Topology
topology.jpg (222.98 KiB) Viewed 753 times

User avatar
matgar
Ultimate Member
Posts:
743
Joined:
Wed Nov 17, 2010 5:53 pm
Certs:
CCNP, CCIP, CCNA Security

Configuration RIPng

Wed May 16, 2012 5:41 pm

The routers are sending routes.
You can see that each router knows about the only wan link thats not directly connected.

You only enabled RIPng on the WAN links you know, so if you wanted the LAN segments to be announced you need to turn that on.


Btw im new to ipv6, can someone explain why the configured interface IPs show up as a local/128 when there is a connected /64 route?

'

Return to IPv6

Who is online

Users browsing this forum: No registered users and 2 guests