User comments to blog posts.
User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

MPLS VPN with OPSF and OSPF-Sham Link Customers

Mon Nov 01, 2010 11:45 am


barbrady
New Member
Posts:
1
Joined:
Sun Oct 02, 2011 5:18 am
Certs:
CCNA, CCNP, CCIP

Re: MPLS VPN with OPSF and OSPF-Sham Link Customers

Sun Oct 02, 2011 5:23 am

Hi, great overview, but your worked example is actually missing the Sham link commands in step 5.

PE1

router ospf 2 vrf C2
area 0 sham-link 2.2.2.1 2.2.2.2

PE2
router ospf 2 vrf C2
area 0 sham-link 2.2.2.2 2.2.2.1


Cheers.

User avatar
ristau5741
Post Whore
Posts:
10618
Joined:
Tue Aug 21, 2007 2:15 pm
Certs:
Instanity

Re: MPLS VPN with OPSF and OSPF-Sham Link Customers

Mon Oct 03, 2011 8:06 am

Where's the mention of the OSPF Superbackbone ?

Ahh, you didn't try connecting OSPF area 0's
Tips of the day:
- The human mind is the ultimate creation invention.
- I have so many customers, my customers have customers.
- Sausage time
- POP, stack, and store

dong
New Member
Posts:
18
Joined:
Sat Nov 30, 2013 7:20 pm
Certs:
CCIE R&S, JNCIP, MCSE

Re: MPLS VPN with OPSF and OSPF-Sham Link Customers

Sun Dec 01, 2013 1:44 pm

Some points regarding the above OSPF-sham link cross the MPLS vpn to connect two CE's ospf area 0:

1. In Step 5, you missing the Shame link configuration portion as mentioned by Barbrady above, also, you can reduce the shame line cost instead of incresing the two interface cost, like, area 0 sham-link 2.2.2.1 2.2.2.2 cost 1 in PE1 and area 0 sham-link 2.2.2.2 2.2.2.1 cost 1 in PE2.

2. In Step 5, you don't need to advertise loopback1 into bgp vrf address family. You already configure reditribute connected in step 4, those lo1 will be redistributed to bgp af vrf automatically.

3. When you reditribute ospf to bgp, if you need to include both internal/external routes, you can do the following configure in PE1 under bgp 65001,
PE1(config)#router bgp 65001
PE1(config-router)# address-family ipv4 vrf C1
PE1(config-router-af)# redistribute connected
PE1(config-router-af)# redistribute ospf 1 vrf C1 match internal e 1 e 2
PE1(config-router-af)# address-family ipv4 vrf C2
PE1(config-router-af)# redistribute connected
PE1(config-router-af)# redistribute ospf 2 vrf C2 match internal e 1 e 2

Same as in PE2

Some fine tuning (optional):
a) CE will learn two E2 routes from ISP, those are the Lo1 of PE dedicated for shame-link, if you don't want CE to learn these two routes, you can configure distribute-list under ospf session in CE to filter these two routes.
Dong

Network Engineer
www.3anetwork.com/blog

'

Return to Blog Comments

Who is online

Users browsing this forum: No registered users and 4 guests