All other Cisco networking related discussions.
User avatar
Kaiga
Senior Member
Posts:
341
Joined:
Thu Oct 21, 2010 9:08 am
Certs:
CCNA, CCENT, A+, Net+

Annoying little 2600 bug

Tue Jul 26, 2016 4:40 am

So we have a bunch of cheap Cisco 2600 (2621/XM, 2611) routers deployed around our areas we use for console/terminal access for our out of band access. (Just using a mix of 16 or 32 Async cards)

There is a little bug that I've been looking around for a solution for, I'm pretty sure its the version of IOS we are using (12.3(8)T6), right now upgrading the IOS on all these terminal servers proves to be too time consuming and that idea isn't an accepted proposal yet, so thats out of the question. Deploying a basic OSPF configuration (to get these things arp fired up after boot via mulicasting) is out of the question as well unfortunately.

The problem I'm having, is when they lose power (sometimes plug strips are moved, or building power goes out, or they get unplugged), and they power back up, they don't come back online on their own. Generally you have to get someone to console into the router itself and have them ping across the ethernet interface to the otherside of the /31 in order for them to come back online and become reachable.

They sit on basic switches in our out of band network which form a ring on our optical transport. Really basic config. One uplink interface:

Code: Select all
interface FastEthernet0/0
 description ge to Juniper/CiscoSwitch Interface ##
 ip address ##.##.##.## 255.255.255.254
 no ip redirects
 no ip proxy-arp
 no ip mroute-cache
 duplex auto
 speed auto
 no keepalive
 no cdp enable
end


Does anyone happen to have any ideas how to get these to come back online on their own? I don't know if a static arp/mac entry will work or not because I don't have a live one to test it out on yet. Does anyone maybe know how to get a script on these to run after they boot up and IOS is loaded to send a couple hundred pings across their uplink interface to get it back online?
http://3rdlayer.wordpress.com/
See most people talk about the OSI model as having 7 layers but they don't mention layer 8 where a lot of the problems actually occur.

'
Return to Cisco General

Who is online

Users browsing this forum: No registered users and 27 guests