RIP, EIGRP, OSPF, IS-IS, BGP, MPLS, VTP, STP.
anktarius
New Member
Posts:
19
Joined:
Tue Nov 26, 2013 5:58 am
Certs:
CCNA

MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 7:00 am

Hello everyone !!! :)

I am trying since some days to make a MPLS HUB & SPOKE .

To do that i use BGP, MP-BGP, OSPF to discover each loopback, VRF to make the way for the VPN HUB & SPOKE.

I use my loopback as Update-source for the BGP, i configure VPNV4 for each vrf but i have problem, so i think i made some mistake.

Now, each PE is able to see his CE network but they are no redistributing this network to all P & PE of my AS 1200.

If anyone can help to understand what i am doing wrong.

I attach a picture of my topology and configuration of my 7200.
topology.png
topology.png (46.51 KiB) Viewed 8990 times
ProjetWAN.zip
(56.02 KiB) Downloaded 128 times


Thanks a lot !

EDIT :
I put here all config file :


POP-PAR1 :

Code: Select all
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname POP-PAR1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip vrf HUBIWAN
 rd 1200:101
 route-target export 1200:1
!
ip vrf MR_SPOKE
 rd 1200:102
 route-target import 1200:2
 route-target import 1200:3
 route-target import 1200:4
 route-target import 1200:5
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface Serial1/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/4
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/5
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/6
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/7
 ip address 200.200.200.2 255.255.255.252
 serial restart-delay 0
 clock rate 64000
!
interface GigabitEthernet2/0
 ip address 10.0.0.13 255.255.255.252
 negotiation auto
 mpls ip
!
interface GigabitEthernet3/0
 ip address 10.0.0.10 255.255.255.252
 negotiation auto
 mpls ip
!
interface GigabitEthernet4/0
 ip vrf forwarding HUBIWAN
 ip address 172.16.1.1 255.255.255.252
 negotiation auto
!
interface GigabitEthernet5/0
 ip vrf forwarding MR_SPOKE
 ip address 172.16.1.5 255.255.255.252
 negotiation auto
!
router ospf 100
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.0.0.0 0.255.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
router bgp 1200
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.2 remote-as 1200
 neighbor 1.1.1.2 update-source Loopback0
 neighbor 1.1.1.3 remote-as 1200
 neighbor 1.1.1.3 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 1.1.1.2 activate
  neighbor 1.1.1.2 send-community extended
  neighbor 1.1.1.3 activate
  neighbor 1.1.1.3 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf MR_SPOKE
  neighbor 172.16.1.6 remote-as 65001
  neighbor 172.16.1.6 activate
  no synchronization
 exit-address-family
 !
 address-family ipv4 vrf HUBIWAN
  neighbor 172.16.1.2 remote-as 65001
  neighbor 172.16.1.2 activate
  neighbor 172.16.1.2 as-override
  neighbor 172.16.1.2 allowas-in
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server



POP-RON1 :

Code: Select all
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname POP-RON1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip vrf MR_SPOKE
 rd 1200:2
 route-target export 1200:2
 route-target import 1200:1
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username projet secret 5 $1$W/0e$Tj/j5.P3yDiwNWmoESusi1
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet1/0
 description --- VERS POP BORDEAUX ---
 ip address 10.0.0.6 255.255.255.252
 negotiation auto
 mpls ip
!
interface GigabitEthernet2/0
 description --- VERS POP PARIS ---
 ip address 10.0.0.9 255.255.255.252
 negotiation auto
 mpls ip
!
router ospf 100
 router-id 1.1.1.2
 log-adjacency-changes
 network 1.0.0.0 0.255.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
router bgp 1200
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1200
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.4 remote-as 1200
 neighbor 1.1.1.4 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
  neighbor 1.1.1.4 activate
  neighbor 1.1.1.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf MR_SPOKE
  neighbor 1.1.1.1 remote-as 1200
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.4 remote-as 1200
  neighbor 1.1.1.4 activate
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server


POP-BDX1 :

Code: Select all
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname POP-BDX1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip vrf MR_SPOKE
 rd 1200:4
 route-target export 1200:4
 route-target import 1200:1
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username projet secret 5 $1$JT.r$XR960RYk5PuAvKOmVdFWa/
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.4 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet2/0
 description --- VERS POP ROUEN ---
 ip address 10.0.0.5 255.255.255.252
 negotiation auto
 mpls ip
!
interface GigabitEthernet3/0
 description --- VERS POP PAU ---
 ip vrf forwarding MR_SPOKE
 ip address 192.168.0.1 255.255.255.252
 negotiation auto
!
router ospf 100
 router-id 1.1.1.4
 log-adjacency-changes
 network 1.0.0.0 0.255.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
router bgp 1200
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.2 remote-as 1200
 neighbor 1.1.1.2 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
  neighbor 1.1.1.2 activate
  neighbor 1.1.1.2 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf MR_SPOKE
  neighbor 1.1.1.2 remote-as 1200
  neighbor 1.1.1.2 activate
  neighbor 192.168.0.2 remote-as 65002
  neighbor 192.168.0.2 activate
  no synchronization
 exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server


Bordeaux-S1 :

Code: Select all
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Bordeaux-S1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.10.1 255.255.255.0
 duplex half
!
interface GigabitEthernet3/0
 ip address 192.168.0.2 255.255.255.252
 negotiation auto
!
interface GigabitEthernet4/0
 ip address 192.168.11.1 255.255.255.0
 negotiation auto
!
router bgp 65002
 no synchronization
 bgp log-neighbor-changes
 network 192.168.11.0
 neighbor 192.168.0.1 remote-as 1200
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server



Siege_social :

Code: Select all
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Siege_Social
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
no ip domain lookup
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username projet secret 5 $1$ksHJ$I7IQRMKRl4wMyAujzihIM0
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
!
interface GigabitEthernet1/0
 ip address 192.168.10.1 255.255.255.0
 negotiation auto
!
interface GigabitEthernet4/0
 ip address 172.16.1.2 255.255.255.252
 negotiation auto
!
interface GigabitEthernet5/0
 ip address 172.16.1.6 255.255.255.252
 negotiation auto
!
interface GigabitEthernet6/0
 no ip address
 shutdown
 negotiation auto
!
router ospf 100
 log-adjacency-changes
!
router bgp 65001
 no synchronization
 bgp log-neighbor-changes
 network 192.168.10.0
 neighbor 172.16.1.1 remote-as 1200
 neighbor 172.16.1.5 remote-as 1200
 no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server


I put here only the left side of my topology if i understand this part i will be able to solve issu in other side :D
Last edited by anktarius on Tue Nov 26, 2013 7:41 am, edited 1 time in total.

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 7:33 am

Post your configs here in code tags. Downloading zips is a nightmare

anktarius
New Member
Posts:
19
Joined:
Tue Nov 26, 2013 5:58 am
Certs:
CCNA

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 7:59 am

Thank for yor reply !

I edited my first post, i post only the left side of my topology if i understand the problem i will be able to learn to solve issue on the right side.

Thanks !

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 8:26 am

From the three PE routers can you type and display the following:

Code: Select all
show bgp vpnv4 unicast all sum
show bgp vpnv4 unicast all
sh mpls forwarding

anktarius
New Member
Posts:
19
Joined:
Tue Nov 26, 2013 5:58 am
Certs:
CCNA

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 8:38 am

For POP-BDX1 :

Code: Select all
POP-BDX1#show bgp vpnv4 unicast all sum
BGP router identifier 1.1.1.4, local AS number 1200
BGP table version is 6, main routing table version 6
1 network entries using 137 bytes of memory
1 path entries using 68 bytes of memory
3/1 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 625 total bytes of memory
BGP activity 1/0 prefixes, 3/2 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4  1200      35      40        6    0    0 00:31:57        0
1.1.1.2         4  1200       0       0        0    0    0 never    Active
192.168.0.2     4 65002      50      46        6    0    0 00:12:15        1
POP-BDX1#show bgp vpnv4 unicast all
BGP table version is 6, local router ID is 1.1.1.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1200:4 (default for vrf MR_SPOKE)
*> 192.168.11.0     192.168.0.2              0             0 65002 i
POP-BDX1#sh mpls forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     10.0.0.8/30       0          Gi2/0      10.0.0.6
17     16          10.0.0.12/30      0          Gi2/0      10.0.0.6
18     17          1.1.1.1/32        0          Gi2/0      10.0.0.6
19     Pop tag     1.1.1.2/32        0          Gi2/0      10.0.0.6
20     18          1.1.1.3/32        0          Gi2/0      10.0.0.6
21     19          10.0.0.16/30      0          Gi2/0      10.0.0.6
22     21          1.1.1.5/32        0          Gi2/0      10.0.0.6
23     Untagged    192.168.11.0/24[V]   \
                                     0          Gi3/0      192.168.0.2
POP-BDX1#


For POP-TLS1 :

Code: Select all
POP-TLS1#show bgp vpnv4 unicast all sum
BGP router identifier 1.1.1.5, local AS number 1200
BGP table version is 6, main routing table version 6
1 network entries using 137 bytes of memory
1 path entries using 68 bytes of memory
3/1 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 625 total bytes of memory
BGP activity 2/1 prefixes, 3/2 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.3         4  1200      37      42        6    0    0 00:33:31        0
1.1.1.3         4  1200       0       0        0    0    0 never    Active
192.168.1.2     4 65003      48      45        6    0    0 00:13:23        1
POP-TLS1#show bgp vpnv4 unicast all
BGP table version is 6, local router ID is 1.1.1.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1200:5 (default for vrf MR_SPOKE)
*> 192.168.12.0     192.168.1.2              0             0 65003 i
POP-TLS1#sh mpls forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
17     Pop tag     10.0.0.12/30      0          Gi1/0      10.0.0.17
18     17          10.0.0.8/30       0          Gi1/0      10.0.0.17
19     19          10.0.0.4/30       0          Gi1/0      10.0.0.17
20     16          1.1.1.1/32        0          Gi1/0      10.0.0.17
21     18          1.1.1.2/32        0          Gi1/0      10.0.0.17
22     Pop tag     1.1.1.3/32        0          Gi1/0      10.0.0.17
23     20          1.1.1.4/32        0          Gi1/0      10.0.0.17
24     Untagged    192.168.12.0/24[V]   \
                                     0          Gi3/0      192.168.1.2


For POP-PAR1 :
Code: Select all
POP-PAR1#show bgp vpnv4 unicast all sum
BGP router identifier 1.1.1.1, local AS number 1200
BGP table version is 3, main routing table version 3
2 network entries using 274 bytes of memory
2 path entries using 136 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
1 BGP extended community entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 830 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 15 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.2         4  1200      38      40        3    0    0 00:34:17        0
1.1.1.3         4  1200      38      40        3    0    0 00:34:27        0
172.16.1.2      4 65001      39      38        3    0    0 00:35:04        1
172.16.1.6      4 65001      39      38        3    0    0 00:35:03        1
POP-PAR1#show bgp vpnv4 unicast all
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1200:1 (default for vrf HUBIWAN)
*> 192.168.10.0     172.16.1.2               0             0 65001 i
Route Distinguisher: 1200:102 (default for vrf MR_SPOKE)
*> 192.168.10.0     172.16.1.6               0             0 65001 i
POP-PAR1#sh mpls forwarding
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop
tag    tag or VC   or Tunnel Id      switched   interface
16     Pop tag     1.1.1.3/32        0          Gi2/0      10.0.0.14
17     Pop tag     10.0.0.16/30      0          Gi2/0      10.0.0.14
18     Pop tag     10.0.0.4/30       0          Gi3/0      10.0.0.9
19     Pop tag     1.1.1.2/32        0          Gi3/0      10.0.0.9
20     20          1.1.1.4/32        0          Gi3/0      10.0.0.9
21     Untagged    192.168.10.0/24[V]   \
                                     0          Gi4/0      172.16.1.2
22     Untagged    192.168.10.0/24[V]   \
                                     0          Gi5/0      172.16.1.6
23     21          1.1.1.5/32        0          Gi2/0      10.0.0.14
POP-PAR1#

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 8:55 am

I'm a bit confused about this:

Code: Select all
1.1.1.2         4  1200      35      40        6    0    0 00:31:57        0
1.1.1.2         4  1200       0       0        0    0    0 never    Active


1.1.1.3         4  1200      37      42        6    0    0 00:33:31        0
1.1.1.3         4  1200       0       0        0    0    0 never    Active



1.1.1.2 and 1.1.1.3 don't have a session to 1.1.1.1?

anktarius
New Member
Posts:
19
Joined:
Tue Nov 26, 2013 5:58 am
Certs:
CCNA

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 9:00 am

Normally they have a session with it but i don't understand the output of this command.
I use bgp 1200 and i indicated neightbors and address family ipv4 vrf MR_SPOKE with this neightboors but i have any idea what it doesn't work and why i get this output :/

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 9:08 am

Why does your hub have vpnv4 connections to 1.1.1.2 and 1.1.1.3 ?

It would need to have vpnv4 connections to the PE's connected to the customer - i.e. 1.1.1.4 and 1.1.1.5


What is the purpose of 1.1.1.2 and 1.1.1.3 in your diagram? They only look like P routers to me, not PE

anktarius
New Member
Posts:
19
Joined:
Tue Nov 26, 2013 5:58 am
Certs:
CCNA

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 9:21 am

1.1.1.2 and 1.1.1.3 is normally POP like 1.1.1.4 and 1.1.1.5 but i haven't put any CE after it.

If needed i can delete 1.1.1.2 and 1.1.1.3 to simplify the topology, it's possibily to complex for my level.

I need to modify my vrf hub ?

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 9:27 am

Ok. But in order for your hub and spokes to talk to each other, the PEs connecting them need to have a vpnv4 session between them, which you don't have

anktarius
New Member
Posts:
19
Joined:
Tue Nov 26, 2013 5:58 am
Certs:
CCNA

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 9:33 am

But on my 1.1.1.2 router i wrote this command :

Code: Select all
router bgp 1200
 no synchronization
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 1200
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.4 remote-as 1200
 neighbor 1.1.1.4 update-source Loopback0
 no auto-summary
 !
address-family vpnv4
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.1 send-community extended
  neighbor 1.1.1.4 activate
  neighbor 1.1.1.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf MR_SPOKE
  neighbor 1.1.1.1 remote-as 1200
  neighbor 1.1.1.1 activate
  neighbor 1.1.1.4 remote-as 1200
  neighbor 1.1.1.4 activate
  no synchronization
 exit-address-family
!


This list of command doesn't establish a vpnv4 sessions beetwen PE ?

Thanks for your help

Ankta'

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 9:35 am

But your 1.1.1.2 router is not a PE connected to the CE

anktarius
New Member
Posts:
19
Joined:
Tue Nov 26, 2013 5:58 am
Certs:
CCNA

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 10:14 am

I have removed 1.1.1.2 and 1.1.1.3 and adapt neighbors to the new topology ( modify loopback neightbors )
And now it works, i have all routes but i still don't understand why my two intermediates LSR cause my topology don't works.

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 10:19 am

As noted. The PE routers in an L3VPN scenario need to be peered directly with each other, or through a route-reflector.

You had your PE router connected to two P routers. The PE routers on the edge were not connected via a vpnv4 session to your hub PE

User avatar
wintermute000
Post Whore
Posts:
1008
Joined:
Mon Jan 14, 2013 10:40 pm

Re: MPLS HUB & SPOKE & VRF

Tue Nov 26, 2013 7:27 pm

also you are using allow-as in and as-override simultaneously.

'

Return to Cisco Routing and Switching

Who is online

Users browsing this forum: KimkeynC and 94 guests