RIP, EIGRP, OSPF, IS-IS, BGP, MPLS, VTP, STP.
hypoxia
New Member
Posts:
2
Joined:
Sat Dec 04, 2010 10:51 pm

Trunking Cisco 1841 and Brocade ICX 7250

Wed Apr 19, 2017 5:56 pm

Hey all,

Long time lurker and networking beginner.

I'm having a problem wrapping around getting layer 2 vlans to work with a subinterface on a cisco 1841. From what I've read I need to create the FA port as a trunk port to the uplink on the brocade device.

This is how everything is connected.

Datacenter > Cisco 1841 > Brocade ICX 7250 > Brocade ICX 6430

Before I go on here's the config

Code: Select all
Current configuration : 3062 bytes
!
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging message-counter syslog
enable secret 5 $1$6J3/$NYvtUf9RKm2W1ilAShSnw1
!
no aaa new-model
clock timezone PST -8
dot11 syslog
no ip source-route
!
!
!
!
ip cef
ip domain name xxxxx
login block-for 100 attempts 5 within 100
login delay 10
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
username xxxxx password 7 12342519130C5F166B
archive
 log config
  hidekeys
!
!
!
!
!
ip tcp synwait-time 10
ip ssh version 2
!
!
!
interface FastEthernet0/0
 ip address 10.4.5.94 255.255.255.0
 ip flow ingress
 ip flow egress
 ip ospf authentication message-digest
 ip ospf authentication-key 7 123E551B165802
 ip ospf network point-to-multipoint non-broadcast
 ip ospf cost 100
 ip ospf mtu-ignore
 ip ospf 39 area 0
 speed auto
 full-duplex
!
interface FastEthernet0/1
 ip address 10.5.94.1 255.255.255.0
 ip flow ingress
 ip flow egress
 ip ospf 39 area 0
 duplex auto
 speed auto
!
interface FastEthernet0/1.1
 encapsulation dot1Q 205
 ip address 10.94.205.1 255.255.255.0
 no cdp enable
!
router ospf 39
 router-id 10.5.94.1
 log-adjacency-changes
 area 0 authentication message-digest
 network 10.4.5.0 0.0.0.255 area 0
 network 10.5.94.0 0.0.0.255 area 0
 neighbor 10.4.5.1
 neighbor 10.4.5.100 cost 100
!
ip default-gateway 172.17.205.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip flow-export version 5
ip flow-export destination 172.19.0.25 2055
!
!
!
logging 172.19.0.25
access-list 111 permit tcp 10.10.0.0 0.0.255.255 any eq www
access-list 111 permit tcp 10.10.0.0 0.0.255.255 any eq 443
no cdp run

!
!
!
!
!
snmp-server community holden RW
!
control-plane
!
!
banner motd ^C

^C
!
line con 0
 exec-timeout 5 0
line aux 0
line vty 0 4
 password 7 123E551B165802456B6A
 login local
 transport input ssh
line vty 5 15
 login local
 transport input ssh
!
scheduler allocate 20000 1000
end



I created the 0/1.1 sub interface for vlan 205. Now to my understanding I need to make 0/1 a trunk port to allow multiple vlans through and then trunk the uplink on the Brocade ICX 7250. I can ping the gateway I'm using for vlan 205 from this switch to the datacenter just fine. Can someone kind of help me out here?

Thanks!

rstafl
Junior Member
Posts:
86
Joined:
Thu Sep 06, 2012 11:34 pm
Certs:
CCIE R&S #48750

Re: Trunking Cisco 1841 and Brocade ICX 7250

Thu Apr 20, 2017 6:16 am

Hi,

Your Fa0/1 configuration looks correct. "encapsulation dot1Q 205" sets the port as a trunk and tags the frames as VLAN 205. Side note, you should remove passwords from the configuration, type 7 passwords can be very easily decrypted using google.

Regards,
R.

'

Return to Cisco Routing and Switching

Who is online

Users browsing this forum: No registered users and 86 guests