Site announcements from the admin and moderators.
User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Creative Routing Contest

Wed Mar 30, 2011 7:45 am

Creative Routing Contest

Well, we made it through the first CCNA scholarship and now it's time for something everybody can participate in again. For this one, a topology will be provided and it will be up to the contestants to configure the routers. The object is to use your creativity to get a packet to traverse every router in the topology before eventually arriving at the far end. The topology is simple, but the possible solutions are many.

Topology

Image

Interface Configurations

R1 Config
Code: Select all
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
interface FastEthernet0/0
description R3 F0/0
ip address 10.1.2.1 255.255.255.0
no shutdown

R2 Config
Code: Select all
interface FastEthernet0/0
description R3 F0/1
ip address 10.1.3.1 255.255.255.0
no shutdown

R3 Config
Code: Select all
interface FastEthernet0/0
description R1 F0/0
ip address 10.1.2.2 255.255.255.0
no shutdown
!
interface FastEthernet0/1
description R2 F0/0
ip address 10.1.3.2 255.255.255.0
no shutdown
!
interface FastEthernet1/0
description R4 F0/0
ip address 10.1.4.2 255.255.255.0
no shutdown
!
interface FastEthernet2/0
description R5 F0/0
ip address 10.1.5.2 255.255.255.0
no shutdown

R4 Config
Code: Select all
interface FastEthernet0/0
description R3 F1/0
ip address 10.1.4.1 255.255.255.0
no shutdown

R5 Config
Code: Select all
interface Loopback0
ip address 10.1.6.1 255.255.255.255
interface FastEthernet0/0
!
description R3 F2/0
ip address 10.1.5.1 255.255.255.0
no shutdown


Example Trace Route Output

Code: Select all
R1#traceroute 10.1.6.1 source loopback 0

Type escape sequence to abort.
Tracing the route to 10.1.6.1

  1 10.1.2.2 40 msec 44 msec 4 msec
  2 10.1.3.1 40 msec 4 msec 28 msec
  3 10.1.3.2 40 msec 16 msec 12 msec
  4 10.1.4.1 40 msec 4 msec 32 msec
  5 10.1.4.2 20 msec 12 msec 16 msec
  6 10.1.5.1 56 msec *  72 msec


Rules?

  • After issuing the command "traceroute 10.1.6.1 source loopback 0" on R1, the resulting packets must cross all routers in the topology.
  • The physical interfaces, topology, and pre-defined IP addressing can not be changed.
  • ZIP your router config *CHANGES* and resulting traceroute and email them to steve at spish dot net. Include your forum username.
  • The contest ends on 4/6/2011 at 2:00PM CST.

The Judges


Other Details

  • Blog, Facebook, and tell your geeks friends about this. The more the merrier.
  • Don't get your feelings hurt, this is just for fun.
  • The rules and details of the contest can change at any time.

Prizes


http://www.networking-forum.com/images/merchandise/longsleeve.jpghttp://www.networking-forum.com/images/merchandise/tshirt.jpghttp://www.networking-forum.com/images/merchandise/beerstein.jpghttp://www.networking-forum.com/images/merchandise/mug.jpghttp://www.networking-forum.com/images/merchandise/sticker.jpg

  • 2nd and 3rd Place - A sticker from the site's swag store

Image

User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Re: Creative Routing Contest

Wed Mar 30, 2011 7:49 am

Don't forget to use the Twitter and Facebook buttons above the announcement post. Thanks. :)

Khipset
New Member
Posts:
4
Joined:
Tue Mar 30, 2010 1:20 pm

Re: Creative Routing Contest

Wed Mar 30, 2011 7:12 pm

Does the trace have to display each hop, or is the packet traversing the router/interface enough?

User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 7:47 am

Khipset wrote:Does the trace have to display each hop, or is the packet traversing the router/interface enough?


The hops need to show though not in any particular order.

User avatar
bman
Senior Member
Posts:
334
Joined:
Fri Feb 11, 2011 4:01 pm
Certs:
CCNP, Sec+, Net+

Re: Creative Routing Contest

Thu Mar 31, 2011 8:08 am

submitted :)
http://blog.flappyport.com

User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 8:13 am

Got it bman. And at least 3 others. I will start posting these up in the separate judging forum today.

User avatar
bman
Senior Member
Posts:
334
Joined:
Fri Feb 11, 2011 4:01 pm
Certs:
CCNP, Sec+, Net+

Re: Creative Routing Contest

Thu Mar 31, 2011 8:30 am

Where is the judging forum?
http://blog.flappyport.com

User avatar
Digitowel
Ultimate Member
Posts:
618
Joined:
Tue Feb 03, 2009 1:54 pm
Certs:
CCIE R&S, NP/DP/IP

Re: Creative Routing Contest

Thu Mar 31, 2011 8:49 am

Mordor.
And actually I appreciate MS certified people quite a bit. Not in the " I wish I did what you did" kinda way, but in a "I'm glad you're doing that so I don't have to" kind way. - Infinite ca. 2010

User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 8:50 am

bman wrote:Where is the judging forum?


It's a hidden forum...for the judges.

User avatar
bman
Senior Member
Posts:
334
Joined:
Fri Feb 11, 2011 4:01 pm
Certs:
CCNP, Sec+, Net+

Re: Creative Routing Contest

Thu Mar 31, 2011 8:58 am

Oh no shit. I am out of it.
http://blog.flappyport.com

jacksonh
Senior Member
Posts:
485
Joined:
Wed Dec 29, 2010 1:01 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 9:14 am

Can we submit multiple entries for multiple solutions (so long as they are distinct enough...)?
I don't have a signature.

User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 9:18 am

Sure, submit as many as you'd like.

User avatar
bman
Senior Member
Posts:
334
Joined:
Fri Feb 11, 2011 4:01 pm
Certs:
CCNP, Sec+, Net+

Re: Creative Routing Contest

Thu Mar 31, 2011 9:26 am

I am curious if you could provide more guidance on what is being judged exactly? Sleekness? Simple implementation?
http://blog.flappyport.com

User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 9:28 am

I suspect the judges (Vito) will go out on their own a bit, but the intention is to judge for creativity. Most of the submissions thus far have been very simple solutions. I personally would like to see somebody do this in a way that nobody else has thought of.

haccduder
Ultimate Member
Posts:
592
Joined:
Sat Oct 09, 2010 2:13 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 9:34 am

when is the deadline to get entries in?

User avatar
Steve
Site Admin
Posts:
10617
Joined:
Mon Dec 06, 2004 6:46 pm
Certs:
CCNA

Re: Creative Routing Contest

Thu Mar 31, 2011 9:35 am

haccduder wrote:when is the deadline to get entries in?


(Take a look at the first post.)

User avatar
scottsee
Post Whore
Posts:
1804
Joined:
Wed Feb 10, 2010 2:45 am
Certs:
NA:R&S, NA:Sec

Re: Creative Routing Contest

Thu Mar 31, 2011 9:54 am

Steve wrote:I suspect the judges (Vito) will go out on their own a bit, but the intention is to judge for creativity. Most of the submissions thus far have been very simple solutions. I personally would like to see somebody do this in a way that nobody else has thought of.


Not the most efficient, just the most creative, complex, unnecessarily intricate method of making this work? The Microsoft way?

User avatar
mellowd
CCIE #38070
Posts:
13814
Joined:
Wed Jun 18, 2008 7:49 am
Certs:
CCIE (RS,SP), JNCIE-SP, BC-/SPNE/NP

Re: Creative Routing Contest

Thu Mar 31, 2011 9:57 am

I want to be blown away

User avatar
jdsilva
Post Whore
Posts:
5347
Joined:
Mon Jan 17, 2005 11:01 pm
Certs:
CCNP

Re: Creative Routing Contest

Thu Mar 31, 2011 10:21 am

mellowd wrote:I want to be blown away

That.

User avatar
raven
CCIE #20728
Posts:
1450
Joined:
Thu Aug 09, 2007 11:22 am

Re: Creative Routing Contest

Thu Mar 31, 2011 10:31 am

hehe like that idea, might give it a try .-)
http://ccie20728.wordpress.com/

'
Next

Return to Announcements

Who is online

Users browsing this forum: No registered users and 5 guests